AIX Backup rootvg with tape Ultrium and scan/delete tape device after finished (Share Tape with software backup)

** Myself
#Scan device
/usr/sbin/cfgmgr ;
TAPE=$(lsdev -C | grep "IBM 3580 Ultrium Tape Drive" | awk '{print $1}')
ORADATAVG=oradatavg
APPDATAVG=appdatavg
/usr/sbin/chdev -l ${TAPE} -a block_size=1024 ;
#Backup by savevg
/usr/bin/savevg -f /dev/${TAPE}.1 -i ${APPDATAVG} ;
/usr/bin/savevg -f /dev/${TAPE}.1 -i ${ORADATAVG} ;
 
#Remove tape device
/usr/sbin/rmdev -dl $(lsdev -C | grep "PCI-XDDR Dual Channel" | awk '{print $1}') -R
/usr/sbin/lsdev -C | grep "PCI Bus" | awk '{print $1}' | while read LINE;
   do
      /usr/sbin/rmdev -dl ${LINE};
   done

0 comments:

Loading