**Myself
Step restore client from Ignite server
1. Interrupt boot os
2. Boot ignite tape version ignite from tape = ignite server
-or-
Boot DVD media version ignite from media = ignite server
-or-
Boot lan (same subnet if not config boot-helper)
Bo lan.XX.XX.XX.XX install (XX=ip ignite server)
3. In Install Welcome sceen ,choose Ignite-UX and Advance install
4. Choose Archive file from ignite server
5. Check space ,dump file ,vg and all
6. Go ! to begin installation phase
Screen restore client from Ignite server
Welcome to the HP-UX installation/recovery process!
Use the <tab> key to navigate between fields, and the arrow keys
within fields. Use the <return/enter> key to select an item.
Use the <return/enter> or <space-bar> to pop-up a choices list. If the
menus are not clear, select the "Help" item for more information.
Hardware Summary: System Model: 9000/800/L3000-8x
+---------------------+----------------+-------------------+ [ Scan Again ]
| Disks: 8 (273.6GB) | Floppies: 0 | LAN cards: 5 |
| CD/DVDs: 1 | Tapes: 4 | Memory: 12288Mb |
| Graphics Ports: 0 | IO Buses: 17 | CPUs: 4 | [ H/W Details ]
+---------------------+----------------+-------------------+
[ Install HP-UX ]
[ Run a Recovery Shell ]
[ Advanced Options ]
[ Reboot ] [ Help ]
User Interface and Media Options
This screen lets you pick from options that will determine if an
Ignite-UX server is used, and your user interface preference.
Source Location Options:
[ ] Media only installation
[ ] Media with Network enabled (allows use of SD depots)
[ * ] Ignite-UX server based installation
Power by < Khronos consulting co., ltd. > |
UNIX OS HP-UX Configuration Ignite server for hpvm host for restore vmguest
**Myself
Ignite server vmhost to vmguest
(vmhost=igserv:ip=10.10.10.10,vmguest=quest1:ip=10.10.10.20)
vmhost
Configure ignite server
mkdir –p /backup/igserv
chown bin:bin /backup/igserv
edit /etc/exports
/var/opt/ignite/clients -anon=2
/backup/igserv -anon=2,access=igserv
/backup/igserv -anon=2,access=Scorpion
exportfs -av
umask 033
make_net_recovery -s igserv -x inc_entire=vg00 -a igserv:/backup/igserv -A
receive mac address from vmguest and config ignite client of vmguest
hpvmstatus -P quest1|grep -i lan
vswitch lan vswitch1 1 0 1 0 62-14-4a-59-0d-b6
Ignite server vmhost to vmguest
(vmhost=igserv:ip=10.10.10.10,vmguest=quest1:ip=10.10.10.20)
vmhost
Configure ignite server
mkdir –p /backup/igserv
chown bin:bin /backup/igserv
edit /etc/exports
/var/opt/ignite/clients -anon=2
/backup/igserv -anon=2,access=igserv
/backup/igserv -anon=2,access=Scorpion
exportfs -av
umask 033
make_net_recovery -s igserv -x inc_entire=vg00 -a igserv:/backup/igserv -A
receive mac address from vmguest and config ignite client of vmguest
hpvmstatus -P quest1|grep -i lan
vswitch lan vswitch1 1 0 1 0 62-14-4a-59-0d-b6
Unix OS HP-UX Restore ignite from tape HP-UX 11i(V1)
** Myself
Restore
# interrupt 10 sec to boot tape device
# Choose Advance for change file system (swap,stand,root,..)
# Restore to disk
Post task after complete restore
# Create new mirror
#1.Reduce Secondary disk
vgreduce /dev/vg00 /dev/dsk/${SEC_DISK}
#2. pvcreate the new disk
pvcreate -B /dev/rdsk/${SEC_DISK}
#3. Use mkboot to place boot utilities inthe boot area,the newly created boot disk
mkboot /dev/rdsk/$SEC_DISK
#4. Use mkboot to set quorum into disk
mkboot -a "hpux -lq" /dev/rdsk/$SEC_DISK
mkboot -a "hpux -lq" /dev/rdsk/$PRI_DISK
#5. Extend vg to include new disk
vgextend /dev/vg00 /dev/dsk/${SEC_DISK}
#6. extend lvols to mirror on the disk
for i in /dev/vg00/lv*
do
lvextend -m 1 $i /dev/dsk/${SEC_DISK}
done
#7. Change Boot Path
setboot pri 0/0/…
setboot alt 0/0/…
Restore
# interrupt 10 sec to boot tape device
# Choose Advance for change file system (swap,stand,root,..)
# Restore to disk
Post task after complete restore
# Create new mirror
#1.Reduce Secondary disk
vgreduce /dev/vg00 /dev/dsk/${SEC_DISK}
#2. pvcreate the new disk
pvcreate -B /dev/rdsk/${SEC_DISK}
#3. Use mkboot to place boot utilities inthe boot area,the newly created boot disk
mkboot /dev/rdsk/$SEC_DISK
#4. Use mkboot to set quorum into disk
mkboot -a "hpux -lq" /dev/rdsk/$SEC_DISK
mkboot -a "hpux -lq" /dev/rdsk/$PRI_DISK
#5. Extend vg to include new disk
vgextend /dev/vg00 /dev/dsk/${SEC_DISK}
#6. extend lvols to mirror on the disk
for i in /dev/vg00/lv*
do
lvextend -m 1 $i /dev/dsk/${SEC_DISK}
done
#7. Change Boot Path
setboot pri 0/0/…
setboot alt 0/0/…
Unix OS HP-UX Backup ignite to tape HP-UX (V1,2,3)
** Myself
Include file for make_tape_recovery and make_net_recovery
#/opt/ignite/recovery/mnr_essentials
# Backup Command Ignite
nohup make_tap_recovery –Av & (case rmt/0mn with nohup.out for background session)
make_tap_recovery –Av (case rmt/0mn)
make_tap_recovery –a /dev/rmt/Xmn -Av (case Xmn)
make_tap_recovery –a /dev/rmt/Xmn -Av –x exclude=/oracle (case Xmn with exclude data on mount point file system)
# Duplicate tape ignite to tape
dd if=/dev/rmt/0mn of=/dev/rmt/1mn bs=2k
dd if=/dev/rmt/0m of=/dev/rmt/1m bs=10k
# Duplicate tape ignite to disk
dd if=/dev/rmt/0mn of=/dir1 bs=2k
dd if=/dev/rmt/0m of=/dir2 bs=10k
Include file for make_tape_recovery and make_net_recovery
#/opt/ignite/recovery/mnr_essentials
# Backup Command Ignite
nohup make_tap_recovery –Av & (case rmt/0mn with nohup.out for background session)
make_tap_recovery –Av (case rmt/0mn)
make_tap_recovery –a /dev/rmt/Xmn -Av (case Xmn)
make_tap_recovery –a /dev/rmt/Xmn -Av –x exclude=/oracle (case Xmn with exclude data on mount point file system)
# Duplicate tape ignite to tape
dd if=/dev/rmt/0mn of=/dev/rmt/1mn bs=2k
dd if=/dev/rmt/0m of=/dev/rmt/1m bs=10k
# Duplicate tape ignite to disk
dd if=/dev/rmt/0mn of=/dir1 bs=2k
dd if=/dev/rmt/0m of=/dir2 bs=10k
Step by Step Install Windows 2003 on DL/ML HP Machine
1. install windows 2003 standard edition server
Rom boot 1. boot self-test information, memory, CPU, HD | |
2. Press "Ctrl + S" to enter "HP Ethernet Boot Agent" settings | |
3. It can enter BIOS by F9 | |
SmartStart 4. Add CD-ROM drive will SmartStart, and guide; | |
Assigned Storage iscsi to Linux with NetApp Storage
** Myself
Refer Iscsi for Linux with NetApp
On Linux
Configuration of iscsi /etc/iscsi.conf
DiscoveryAddress= <host of storage>
IncomingUsername=administrator (admin user for admin external storage)
IncomingPassword=password (password admin user for admin external storage)
OutgoingUsername=administrator (admin user for admin external storage)
OutgoingPassword=password (password admin user for admin external storage)
Configuration of iscsi initiator /etc/initiatorname.iscsi
InitiatorName=iqn.1987-05.com.cisco:rhel4
# iqn.1987-05.com.cisco:rhel4 = <identified name by os-generate>:<free name >
list iscsi device
iscsi-ls –l
Iscsi Rescan new device
iscsi-rescan
iscsi id
/var/run/iscsid.pid
Refer Iscsi for Linux with NetApp
On Linux
Configuration of iscsi /etc/iscsi.conf
DiscoveryAddress= <host of storage>
IncomingUsername=administrator (admin user for admin external storage)
IncomingPassword=password (password admin user for admin external storage)
OutgoingUsername=administrator (admin user for admin external storage)
OutgoingPassword=password (password admin user for admin external storage)
Configuration of iscsi initiator /etc/initiatorname.iscsi
InitiatorName=iqn.1987-05.com.cisco:rhel4
# iqn.1987-05.com.cisco:rhel4 = <identified name by os-generate>:<free name >
list iscsi device
iscsi-ls –l
Iscsi Rescan new device
iscsi-rescan
iscsi id
/var/run/iscsid.pid
SAP BASIS Step Shot approve solman download patch from service.sap.com by function module
** Myself
Step Shot approve solman download patch
1) Add file to download basket from service.sap.com
Logon to Solman and run
SE37
/TMWFLOW/MO_UI_BASKET_AUTHORIZ then execute ( F8 )
values I_OSS_RFC = SAP-OSS
execute ( F8 )
Select -> confirm download
Go to web basket
Change from approval list to download basket
(Next step direct download or use sapdownload manager tool)
Step Shot approve solman download patch
1) Add file to download basket from service.sap.com
Logon to Solman and run
SE37
/TMWFLOW/MO_UI_BASKET_AUTHORIZ then execute ( F8 )
values I_OSS_RFC = SAP-OSS
execute ( F8 )
Select -> confirm download
Go to web basket
Change from approval list to download basket
(Next step direct download or use sapdownload manager tool)
SAP BASIS Install SAP 4.7 Enterprise on Windows 2000 with MS SQL Server 2000
** Myself
How to View/Disconnect Remote Desktop Sessions from Command
** Myself with web
How to View/Disconnect Remote Desktop Sessions from Command
Sol1)
I used to receive the maximum number of connections error message when I try to log on to the Windows 2003 Server in my office via Windows Remote Desktop.The terminal server has exceeded the maximum number of allowed connections
This is pretty annoying if you have some urgent work to do in the server. Most of the already logged in users won’t even be using the session at the time, but I can’t login! So how to solve this? After a bit of googling, as usual, I found a simple way to disconnect other remotely logged in sessions.
Pre-Step
Netbackup MS SQL backup Client hold (parent killed) and can’t new backup. (spawn Application-Backup jobs after the parent job was canceled by the administrator) NBU 6.5.3
** Myself
From Task manager
dbbackex.exe (child process from bp process of netbackup)
Cant’ killed
Can’t change template backup file
From Enterprise Manager See SQL process mapping one to one with Netbackup child process.
Select process -> kill process
Refresh view
From Task manager
dbbackex.exe (child process from bp process of netbackup)
Cant’ killed
Can’t change template backup file
From Enterprise Manager See SQL process mapping one to one with Netbackup child process.
Select process -> kill process
Refresh view
How to use the "kill" command in Windows 2000 and "taskkill" command in Windows 2003
** Credit symantac http://seer.entsupport.symantec.com/docs/253904.htm and
window support http://support.microsoft.com/default.aspx?scid=kb;en-us;197155&Product=win2000
To use the kill command to stop the Backup Exec services, do the following:
1. Click Start | Run, and then type cmd and press <Enter>
2. At the command prompt, type kill benetns.exe. This will stop the Backup Exec Agent browser service (Figure 3).
Figure 3
kill process name or id
-or-
kill -f process name or id
3. Repeat steps 2 and 3 for each of the Backup Exec services. The process name will be different for each service. The easiest way to find out their names is to look at the Path to Executable field in the properties of each service. After all Backup Exec services are stopped, they can be restarted to continue using or troubleshooting Backup Exec.
Windows 2003
In Windows 2003, use the taskkill command to stop the Backup Exec services. Do the
window support http://support.microsoft.com/default.aspx?scid=kb;en-us;197155&Product=win2000
To use the kill command to stop the Backup Exec services, do the following:
1. Click Start | Run, and then type cmd and press <Enter>
2. At the command prompt, type kill benetns.exe. This will stop the Backup Exec Agent browser service (Figure 3).
Figure 3
kill process name or id
-or-
kill -f process name or id
###Example
force kill for Backexec process hold dbbackex.exe
(Killed on master server but client can’t terminate)
kill -f benetns.exe or kill –f 1868
###Example
force kill for netbackup process hold dbbackex.exe (Killed on master server but client can’t
terminate)
kill -f dbbackex.exe
3. Repeat steps 2 and 3 for each of the Backup Exec services. The process name will be different for each service. The easiest way to find out their names is to look at the Path to Executable field in the properties of each service. After all Backup Exec services are stopped, they can be restarted to continue using or troubleshooting Backup Exec.
Windows 2003
In Windows 2003, use the taskkill command to stop the Backup Exec services. Do the
Sun Solaris OS Image Procedure
** Credit Web
Restore Procedure
1. Insert the Solaris 10 Software DVD, and boot the DVD with the single-user mode option.ok boot cdrom -s
2. Create the new file system structure.
# newfs /dev/rdsk/c0t0d0s0
3. Mount the file system to the mount point /a and change to that directory.
# mount /dev/dsk/c0t0d0s0 /a
# cd /a
4. Restore dump file on Dataprotector to dummy server (PDS system) for using this server to restore dump file via NFS service
5. Setup interface server to connect dummy server and verify connection
# ifconfig bge0 IP address netmask broadcast up
# ping dummy server
6. Mount the NFS file system from dummy server that located dump file for recovery system
# mount dummy server:/dump file location /a/b
7. Restore the / (root) file system from NFS service.
# cd /a
# ufsrestore rf /a/b/root.dmp .
8. Remove the restoresymtable file.
# rm restoresymtable
9. Install the bootblk in Sectors 1 through 15 of the boot disk. To do this, change to the directory that contains the bootblk, and enter the installboot command.
# cd /usr/platform/`uname -m`/lib/fs/ufs
# installboot bootblk /dev/rdsk/c0t0d0s0
10. Unmount the new file system.
# cd /
# umount /a
11. Use the fsck command to check the restored file system.
# fsck –y /dev/rdsk/c0t0d0s0
12. Perform a full backup of the file system.
# ufsdump 0uf /dev/rmt/0 /dev/rdsk/c0t0d0s0
13. Reboot the system.
# init 6
Oracle Database Basic Command
** Credit Web
Alter
|
||
Application:
|
Altering a users password, making changes to a table or column.
|
|
Change Password:
|
ALTER user username IDENTIFIED BY newpassword
|
|
Example
|
ALTER USER tony IDENTIFIED BY cereal
|
|
Adding a column:
|
ALTER TABLE tablename ADD column name datatype
|
|
Example:
|
ALTER TABLE project ADD names varchar2(25)
|
|
Application:
|
Commit data to a database table.
|
|
Save inserted data
|
Commit
|
|
Application:
|
Allows for the creation of column constraints such as Primary and Foreign keys.
|
|
Create Primary Key
|
CONSTRAINT constraint name_pk PRIMARY KEY
|
|
Example
|
CONSTRAINT cd_cd_id_pk PRIMARY KEY (cd_id)
|
|
{NOTE: this is the format when using at the end of you column declarations in a CREATE Table statement)
|
||
Create a Foreign Key
|
CONSTRAINT constraint name_fk REFERENCES tablename(primary key)
|
|
Example
|
CONSTRAINT cd_cd_id_fk REFERENCES cd(cd_id)
|
|
{NOTE: this is the format when using at the end of you column declarations in a CREATE Table statement)
|
||
ADD a PRIMARY Key Constraint (after table created)
|
ALTER TABLE tablename
|
|
ADD CONSTRAINT constraint name PRIMARY KEY (column name)
|
||
Example
|
ALTER TABLE cd
|
|
ADD CONSTRAINT cd_cd_id_pk PRIMARY KEY(cd_id);
|
||
Add a FOREIGN KEY Constraint (after table created)
|
ALTER TABLE tablename
|
|
ADD CONSTRAINT constraint name REFERENCES table(column name)
|
||
Example
|
ALTER TABLE cd
|
|
ADD CONSTRAINT cd_cd_id_fk REFERENCES cd(cd_id);
|
||
Application:
|
Creates a table,view, index, sequence, user etc. in the database.
|
|
Create Table
|
CREATE TABLE tablename (data definition)
|
|
Example:
|
CREATE TABLE project ( name varchar2(25), activity varchar2(30))
|
|
Create View
|
CREATE VIEW viewname (column names)AS SELECT select statement
|
|
Example:
|
CREATE VIEW report (Names, Addresses) AS SELECT Select name, address FROM book
|
|
Application:
|
Delete a record from a table.
|
|
Delete record
|
DELETE FROM tablename WHERE search condition
|
|
Example:
|
DELETE FROM project WHERE projid = 21
|
|
Oracle Database Renaming a table syntax
** Myself
Oracle Renaming a table syntax
ALTER TABLE table_name
RENAME TO new_table_name;
For example,
ALTER TABLE table1
RENAME TO table2;
Oracle Renaming a table syntax
ALTER TABLE table_name
RENAME TO new_table_name;
For example,
ALTER TABLE table1
RENAME TO table2;
DB2 Database Step by Step Installation and Manage DB2 Instance on AIX [Thai Version]
** Credit K.Vitaya Lorsrichandr
ขั้นตอนการติดตั้งระบบฐานข้อมูล DB2 UDB ESE หรือ WSE บน AIX
1 ตรวจสอบสิ่งที่จำเป็นต้องทำเป็นเบื้องต้น ( Prerequisites )
2 การ Mount แผ่น DB2 Installation CD-ROM
3 ติดตั้งระบบฐานข้อมูล DB2 UDB Enterprise Server Edition หรือ Workgroup
Server Edition
4 ติดตั้ง FixPak ล่าสุด
5 ตรวจสอบการติดตั้งระบบฐานข้อมูล โดยใช้ Command Line Processor (CLP)
6 (ทางเลือก) ติดตั้ง DB2 Information Center
1 ตรวจสอบสิ่งที่จำเป็นต้องทำเป็นเบื้องต้น ( Prerequisites )
1.1 ระบบปฏิบัติการ
DB2 UDB Workgroup Server Edition ทำงานได้บนระบบปฏิบัติการดังนี้
- AIX Version 4.3.3 (32-bit only) with Maintenance Level 11
For JFS filesystems:
APAR IY49385
For Java:
OpenGL.OpenGL_X.rte.base
OpenGL.OpenGL_X.rte.soft
X11.adt.lib
- AIX Version 5.1.0 (32-bit และ 64-bit) with Maintenance Level 5
For JFS filesystems:
APAR IY48735
For JFS2 filesystems:
APAR IY49254
For Java:
Recommend Maintenance Package AIX5100-04 และ APAR IY46667
SAP BASIS Installation Disk,CPU,RAM Requirement for Windows
** Credit http://forums.sdn.sap.com and Sapnote
IDES | R3 |
SAP 4.7 IDES | SAP 4.7 |
Processor --- Intel P4 2.0 or above | Processor --- Intel P4 2.4 or above |
RAM --- 512 MB | RAM --- 512 MB |
Hard Disk --- 80 GB | Hard Disk --- 50 GB |
ECC5 IDES | ECC 5.0 |
Processor --- Intel P4 2.4 or above | Processor --- Intel P4 2.4 or above |
RAM --- 2 GB | RAM --- 1 GB |
Hard Disk --- 160 GB | Hard Disk --- 60 GB |
ECC6 (64 bit) IDES | ECC 6.0 (64 bit) |
Processor --- Intel P4 3.0 dual core | Processor --- Intel P4 3.0 dual core |
RAM --- 3 GB | RAM --- 3 GB |
Hard Disk --- 200 GB | Hard Disk --- 250 GB |
DB sizes are IDES ECC6: |
ORACLE: 200 GB |
MaxDB: 180 GB |
MSSQL: 150 GB |
DB2-UDB 150 GB |
DB2 on iSeries 240 GB |
Unix OS HP-UX Mount CD/DVD-ROM for special character (example ORACLE CD) by pfs_mount
** Credit web
Mounting CD-ROMs for HP
1. Use the following command to determine the device_file:
$ ioscan -fun -C disk
The output should be similar to the following:
disk 10 10/12/5.2.0 sdisk CLAIMED DEVICE TOSHIBA CD-ROM
XM-5701TA /dev/dsk/c4t2d0 /dev/rdsk/c4t2d0
2. If there is not already an entry in the /etc/pfs_fstab file for your CD-ROM
device, you must add one. As the root user, use a system editor to add a line to
the /etc/pfs_fstab file following this format:
device_file mount_point filesystem_type translation_method
In the preceding format, the first entry is the CD-ROM device, the second entry
is the mount point, and the third entry indicates that the CD-ROM to be
mounted is in ISO9660 format with Rockridge extensions.
The device_file in this example is /etc/pfs_fstab. For a CD-ROM
device with the path /etc/pfs_fstab, you would enter the following:
/dev/dsk/c4t2d0 /SD_CDROM pfs-rrip xlat=unix 1 0
#Caution: Do not run the Installer while the CD-ROM
directory is the current directory or you will be unable to
unmount the next CD-ROM when prompted to do so.
Installation Mount Options
3. Enter the following commands:
# nohup /usr/sbin/pfs_mountd &
# nohup /usr/sbin/pfsd &
4. Place CD-ROM in the CD-ROM drive and mount the CD-ROM
by entering the following command:
# /usr/sbin/pfs_mount /SD_CDROM
# To unmount the CD-ROM, use the following command:
# /usr/sbin/pfs_umount /SD_CDROM
Subscribe to:
Posts (Atom)
Loading