Unix OS Shell script HP-UX 11iv2(11.23) and v3 Mirror root disk

** Myself
#1. Please check the path of primary and secondary disk.
PRI_DISK=c2t0d0
PRI_PATH=0/1/1/0.1.0
SEC_DISK=c2t1d0
SEC_PATH=0/1/1/1.2.0
#2. Create temp file.
echo '3' > /tmp/partitionfile
echo 'EFI 500MB' >> /tmp/partitionfile
echo 'HPUX 100%' >> /tmp/partitionfile
echo 'HPSP 400MB' >> /tmp/partitionfile
#3. Use idisk to setup the disk partitioning using the file created above:
idisk -wf /tmp/partitionfile /dev/rdsk/$SEC_DISK
idisk -p /dev/rdsk/$SEC_DISK
#4. Use insf to create the new device dfiles (${SEC_DISK}s1 and ${SEC_DISK}s2)
insf -eC disk
#5. pvcreate the new subpartition - make sure specify s2 !
pvcreate -fB /dev/rdsk/${SEC_DISK}s2
#6. Use mkboot to format and populate the newly created EFI partition:
mkboot -e -l /dev/rdsk/$SEC_DISK
#7. Extend vg to include new disk sub-partition s2.
vgextend /dev/vg00 /dev/dsk/${SEC_DISK}s2
#8. extend lvols to new sub-partition on the disk
for i in /dev/vg00/lv*
do
lvextend -m 1 $i /dev/dsk/${SEC_DISK}s2
done
#9. update lvol boot paths
lvlnboot -r /dev/vg00/lvol3 /dev/vg00
lvlnboot -b /dev/vg00/lvol1 /dev/vg00
lvlnboot -s /dev/vg00/lvol2 /dev/vg00
lvlnboot -d /dev/vg00/lvol2 /dev/vg00
#10. Use efi_ls to confirm that the EFI partition is present and populated on the new disk:
efi_ls -d /dev/rdsk/${SEC_DISK}s1
#11. edit the AUTO file so we can boot when one disk is missing:
efi_cp -d /dev/rdsk/${PRI_DISK}s1 -u /EFI/HPUX/AUTO /tmp/AUTO
echo 'boot vmunix -lq' > /tmp/AUTO
#then put back the file on both EFI partitions with:
efi_cp -d /dev/rdsk/${SEC_DISK}s1 /tmp/AUTO /EFI/HPUX/AUTO
efi_cp -d /dev/rdsk/${PRI_DISK}s1 /tmp/AUTO /EFI/HPUX/AUTO
#12. add the new disk to /stand/bootconf
cp /stand/bootconf /stand/bootconf.old
echo 'l /dev/dsk/${SEC_DISK}s2' >> /stand/bootconf
#13. add EFI primary and high availability boot path menu entries.
setboot -p $PRI_PATH
setboot -h $SEC_PATH
setboot -b on
#14. veritas that the primary and mirror boot path are configured properly.
setboot
#15. Reboot test booting from each drive.
echo 'Mirror disk completed.'
echo 'You should to REBOOT and test booting from each drive.'

0 comments:

Loading